Current time: 03-24-2017, 07:55 PM
Hello There, Guest! Register

OA Crash

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
#1
Hello Dave,

Perhaps a bug ???

So, as said, in my previous post in chartdownloder thread, I uninstall OA and the create a folder android/cartographie on the sd card. Then re-install OA.

Then I try to add suedish chart (kap files by soltek).

Then after a long time, very very long time, the data base finished to built.

Then I try to display these raster charts and then OA stop.

I re-run OA, I try to display the raster charts. Same problem, OA Stop !

I try more, same problem.

Then I add cm93

Then also long time to built data base

Then I display the area of my raster charts but with cm93. No problem

Then I display the same area with raster charts and in this case, no problem. OA do not stop.
Reply
#2
hello Dave,

I have gradually removed notifications from other applications. This afternoon, I did not have a crash. Clearly, the interference of the activities of other applications with that of OpenCPN explains, perhaps, the many crash that I had.

Best regards. Gilletarom.
Reply
#3
Hello Dave,

Concerning the repeated crash of OA:

Yesterday afternoon, I had been able to work normally. To be more peaceful, I had disabled the notifications that other applications emitted.

This afternoon, I tried to download the Raster charts for the New York area, using the chartdownloader. The 94 cards have downloaded correctly. But towards the 20th card, it seems that my wifi connection has temporarily stopped. Something that looks like a micro break.

This is a situation that OA does not like. There was a message saying that 20 cards were only downloaded. I typed Ok on this message and the database update started automatically. It seems to have proceeded normally.

I then tried to view the New York area by zooming in on the city. As soon as the zoom level is too large, crash. I raised, enlarged with the doights, crash. I started again, enlarged with the zoom + button, it ends systematically by a crash.

I complete:
After a while waiting, I resumed my smartphone and restarted OA. I zoomed in but leaving a lot of time between pressing the zoom + button. And this time, no crash.

I also add:
I encounter the same problem with zoom -.
Best regards. Gilletarom.
Reply
#4
Hello Dave,

Sorry to talk about crash but the situation has become impossible to live. I can no longer run OpenCPN.

There are several causes:
- OpenCPN itself
- Androïd
- Doro.

Cause OpenCPN:
I can uninstall OpenCPN and then reinstall OpenCPN. Obviously, at that time, I have only the background map. If I am satisfied, it seems that everything goes well.
As soon as I try to install charts, the construction of the database begins and ends most of the time by a crash.

Cause Androïd:
Can not clean the slag system due to multiple OpenCPN crashes (????)

Cause Doro:
Doro is the brand of the phone. It is a Swedish brand. Last Friday, the phone showed information about a software upgrade. I accepted. My bad . Now, all applications that have their own "Quit" button malfunction. And precisely, OpenCPN has its own function "Quit".

Now, the combination of all these causes makes it impossible to build the database.
Reply
#5
Gilletarom...

Will you give me the exact model number of your phone?  I will research.


Maybe the device does not have enough memory available for OCPN?  We are not hearing of these types of troubles from other users.  Are you submitting the crash information back to Google Playstore when it crashes?  I can get these crash reports anonymously, but I don;t see any recent crash reports that look like your situation.

Thanks, and sorry for the trouble.

Dave
Reply
#6
Hello Dave,

1) My smartphone is a Doro 825.

2) How do we get Google playstore to receive information about crash?

3) As the proposed update for this smartphone was proposed by the manufacturer Doro, I immediately contact Doro's ad-hoc service and explained a good part of my galleys.

I have already seen that this service is very responsive. I expect an answer in the course of the next week.

4 About the problem of internal memory, I do not know whether it is sufficient or not. I bought this phone after comparing:
- the price,
- 8GB internal memory
- the size of the SD card: 16 GB.

It was not a "bottom of game" phone. I ended up thinking he was not that bad. I was able to call, very easily, all summer and I use it to implement a wireless network in the boat. No problem, everything worked well.

That said, there was an internal memory problem. The warranty service had told me how to fix it. But I waited to get back, of my 4 months of navigation, to solve this problem. That is why I only installed OpenCPN at the end of September.

5 ° Now, I observe an additional problem: I managed more or less well to display a charts but it is blurry! I wonder if it's not the SD card that has a problem. I'll test this tomorrow by getting another SD card.

Thank you for the attention given to my posts.
Reply
#7
   
Gilletarom...

1 & 4:
The internal RAM on your phone is 1 GB.  This is plenty for OCPN, and quite the standard specification.

2.  Crash Reports:
You should see a message similar to attached picture (except for App title OpenCPN).  The "Report" button sends the crash report to the Google Playstore, where I can access it privately.

Do you see this?

Thanks
Dave
Reply
#8
Dave,

1° When openCPN stopped, I never see this kind of message on my smartphone. OA stop and the smartphone return at situation before I open OA.

2° No, my smartphone is 8 Go internal with 4,48 Go for me and 3,52 Go for the system.

So normally, it is enouth. But really, with all the apps installed on my PC, there is only about 600 to 700 Mo usable.

See screen copy. Now there is 624 Mo usable (if I undestand the information of this screen).

B.R. Gilletarom.

Attached Files

Thumbnail(s)
   
Reply
#9
Dave,

I discovered why, with each reinstallation, this continued with the previous settings. Settings I thought were erased because I had uninstalled OA!

Two screenshots made in androïd settings. In English "Save and reset" and on this page "Restore automatically". This setting was enabled. So the slag did not disappear !!!!

Now that this parameter is disabled, the database is built correctly.

Attached Files

Thumbnail(s)
       
Reply
#10
Gilletarom...

So, I understand that you have no more crashes?  That is good.

How is the "fuzzy" display?

Dave
Reply




Users browsing this thread: 1 Guest(s)