Current time: 03-23-2017, 02:09 AM
Hello There, Guest! Register
Help function Posted by: Boomdangle - Yesterday, 01:31 PM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (1)

Help function in paid Android version comes up error, cannot find file. Will this be corrected?
Thans

HW recommendations for OpenCPN Posted by: SailPat - 03-09-2017, 09:46 PM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - No Replies

I am looking for recommendations on which HW to pick for OpenCPN on Android. For a tablet/pad and for a phone.
Experience from existent users as to minimum processor/speed/ram/and SD card memory.
I use OpenCPN on my MBP and think its really great so I decided to back that up with an Android tablet/pad and a phone and chuck/sell my iPad and iPhone.
Any input welcome ...
thanks and happy sailing

Ernie

Chart bar at screen bottom not working. Posted by: prjacobs - 03-05-2017, 02:43 PM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (2)

Hello all,
I'm new to this forum, and a new user of OpenCPN Android, although I've been using the PC and Ubuntu versions for several years.
Many thanks to Dave Register for doing such a good job!

I'm running version 1.0.12 on a Nexus 7 (2012) tablet running Android 5.1.1 and using a Yakker NMEA to WiFi bridge for AIS/GPS data from a AIT2000 AIS transponder.

I have a couple of questions:
How does one change charts using the chart bar at the bottom of the screen? I've tried tapping, double tapping, and holding, all to no avail. On my PC version I double-click with the mouse to change charts.

Are there any ways to zoom in and out, apart from screen swiping? I tried the volume up~down control but it did not work.

TIA for any help.
Peter.

Selecting multiple tracks Posted by: richard121249 - 03-02-2017, 09:46 AM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - No Replies

I would like to select more than one track so that I can merge them. How do you do this on OCPN? Normally you would touch screen and hold but that just simulates a right button click.

From cruisersforum.com OpenCPN thread: Android OpenCPN crashes when Adding Connection Posted by: ADroid - 02-13-2017, 06:08 PM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (13)

(This is a verbatim copy of a posting I made at cruisersforum. Dave directed me here. So here goesSmile

I have an IRULU 9" Android tablet on which I installed OpenCPN about a year ago (when it was just released). I paid for it, on the Google Play store. Originally it worked great.

However, during one of the automatic updates, a few months ago, OpenCPN stopped having any use for me. The problem is that I cannot connect to wifi any more. As soon as I click on 'Add a connection' it crashes ("Unfortunately OpenCPN has stopped"). This seems entirely independent on what I enter as parameters, it happens every time. It also happens both on my boat's Wifi network (provided by the Vespermarine AIS transponder) and any other Wifi network I tried elsewhere, at home and at work. 

I "reported' the problem many times but nothing was ever fixed. I did include system logs in all cases. 

Why is wifi essential? Because it gets all the information from my AIS transponder, both location information and, obviously, AIS. Without it, it is a nice book reader but not an (Open) Chartplotter any more. 

The free version (Maison automatique), which I installed at the same time when I bought this one and kept as a backup, does not have the problem. It has other issues (related to chart access) which makes it not really usable either. But I did not pay for it so I cannot really complain. A gifted horse and all that...

Please help. I bought the tablet only to use for OpenCPN and now it is worthless for me

hudl2 Posted by: tonyappuk - 02-02-2017, 10:06 AM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (5)

my HUDL2 has updated to lollipop 5.1 but I can't see my charts on my SD card I can see the SD card in the charts select screen and they are called /storage/sdcard1/Android/data/org.opencpn.opencpn/files. But if I select them or do the usual scan charts or force update I cannot see CM93 or any of the Kap charts that I have loaded on the sd card. I can see them via my PC and using es file explorer. I don't seem to be able to drill down in the folder shown in the charts selection dialogue. Does anyone have any suggestions for what I am doing wrong, please. Tony

OCPN Timeout Posted by: bobmor99 - 01-30-2017, 08:48 PM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (5)

Greetings,
This is likely more of an android than an OCPN question.
I did some mild searching prior to posting this...
My setup has an RPI-3 as the boat-puter (running OCPN of course).
GPS data is fed to the RPI from (Dave's) OCPN on my android phone via a wifi UDP connection.
Works fine. :-)
However, the phone goes to sleep after the android "sleep" limit is reached and the RPI ceases to receive GPS data.
Is there a way to have the OCPN app stay awake on my phone? That would make the RPI very happy.  :-)
Kind regards,
--Bob M

OpenCPN for Android Version 1.0.12 Released Posted by: dsr - 01-23-2017, 12:46 PM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (8)

Announcement
------------

Hello Users...

OpenCPN for Android Version 1.0.12 is now available for download from the Google PlayStore.
If enabled on your device, you will receive an automatic upgrade to this Version.  Or, you may manually upgrade by visiting the Google PlayStore.

See the Changelog below for details regarding upgrades and improvements.

Thanks very much to the Beta testers who contributed lots of valuable time and energy toward making this Release the best ever.
I look forward to your continued support as we move forward with OpenCPN for Android in the mobile world.

Best Regards
Dave



1.0.12 Changelog

OpenCPN for Android Version 1.0.12 has many improvements affecting performance, reliability, and security. Visible user interface changes include the following:

1.  French language support fully implemented.
2.  Improved display rendering on high-display-density devices, especially for Vector charts and AIS overlays.
3.  Improved user interface for Chart Downloader PlugIn, especially affecting the chart catalog selection tree.
4.  Improved support for SDCards, see note below.
5.  Support for additional generic USB device inputs, including AMEC-150 AIS receiver.

SDCard support notes:

Background...
a)  Starting with Android Version 4 (KitKat), access to the SDCard has been limited by the operating system. This was done to improve overall system security, so that one app may not accidentally or intentionally corrupt another app's private data. This change means that it is not possible to write to the card generally, but writing is permitted only in areas (directories) of the card that are allocated to a particular application.
b)  As a further complication, the directory referring to an external SDCard within the Android file system is not generally called "sdcard".  This name, "sdcard" is reserved for emulated external storage space, and really points to internal storage in the device.  The true name for a physical SDCard in Android version 4+ is determined by the device manufacturer, and varies from device to device.  This can (and has) made it difficult to load charts from a PC by USB cable, and then later find and attach them to the OpenCPN chart list.

Mitigation:
We have added "shortcut" buttons to the directory picker dialog in OpenCPN to allow the user to directly navigate to the normal device file storage area, and also directly to the accessible and writable directory space of any physical SDCard installed.  This will affect two common OpenCPN activities.

a)  Connect your device to a PC and transfer some charts to the card, in whatever structure suits you.  Start OpenCPN, and navigate to the "add charts" function. You will be able to touch the "SDCard" shortcut button to access the assigned area of physical card space.  You may then navigate up and down the physical SDCard storage tree to find your new charts.  If you get lost in the structure, touch the "SDCard" shortcut button again to reset. Find your new charts, and select that directory.  The charts will then be available to OpenCPN.  Note that these charts will be "Read-only" to the Android system, unless they are placed in the directory assigned to OpenCPN by the Android system, or a subdirectory of that assigned space.  That is fine, since OpenCPN does not need "write" access to the chart directories in order to display the manually loaded charts.

b)  The Chart Downloader requires "write" access to the directory subtree containing the charts and catalogs.  If you want to store your downloaded charts on the SDCard, and you are using Android Version 5 or higher, you must set the Chart Downloader base directory to the location suggested by the "SDCard" shortcut button in the OpenCPN directory selector dialog, or a subdirectory of that location.  For example, on a particular device, the "SDCard" short-cut location may be something like:  "/storage/CO2C-1BF1/Android/data/org.opencpn.opencpn/files".  The string "CO2C-1BF1" is a UUID associated with this particular card, and will not be the same on your device.  You may reasonably create a new directory called "/storage/CO2C-1BF1/Android/data/org.opencpn.opencpn/files/Charts".  This directory will be "writable" to Android, and so is suitable for Chart Downloader use.  When activated, the Chart Downloader will check to verify that the selected directory is actually "writable" when needed, and show a message dialog to the user if it is not.

MMSI proprties not displayed Posted by: Smaxta.S - 01-23-2017, 05:41 AM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (1)

Dear Dave.

As I use RTL-SDR dongle to catch AIS targets, I want to have my own vessel to always track and use AIVDO messages for it. But in Settings- Ship- MMSI Properties not shows any of entered data. I've check settings file and found, that data stored properly in there.

This bug was present in ver.1.0.10 and now still on 1.0.11 beta

Olek

titlebar not displayed on tablet Posted by: Peter44 - 01-12-2017, 11:47 AM - Forum: OpenCPN for Android Versions 1.0.0 - 1.0.12 - Replies (12)

Hello Dave,
no titlebar being displayed on an android tablet, whether selected or not makes no change.
Version is 1.0.10
The titlebar entry in the conf-file is set correctly, but no change in display.

Kind regards
Peter